Skip to Main Content

Why did the Oracle PHP 7.4 Developer repository stop building against 19c?

user10211287May 11 2022

We have a separately-installed 19c client that we had been able to use with the PHP packages in the developer repository (https://yum.oracle.com/repo/OracleLinux/OL7/developer/php74/x86_64/index.html). With versions after php-oci8-19c-7.4.28-1.0.1.el7, it appears the package is obsoleted and yum/dnf bumps the package version to a 21c build which (obviously) doesn't find the 19c libraries we have on the system. Since 19c is a long-term release and still fully supported by Oracle, I find it odd the repository maintainers are no longer building a 19c version of the php-oci8 module.

Thanks,
Jeff

Comments
Post Details
Added on May 11 2022
0 comments
2 views