Skip to Main Content

ODP.NET

Announcement

For appeals, questions and feedback about Oracle Forums, please email oracle-forums-moderators_us@oracle.com. Technical questions should be asked in the appropriate category. Thank you!

Interested in getting your voice heard by members of the Developer Marketing team at Oracle? Check out this post for AppDev or this post for AI focus group information.

Upgrading ODP/.Net 4 Application to Oracle 19c

b5b06b9a-254d-4fd2-b91b-986a1db7bd4cJul 17 2020 — edited Jul 17 2020

Hello, I'm running into an error while updating my Oracle client on an application server running a .Net 4 application on IIS 7, which is using the Oracle data provider for .Net in the GAC.

The error from the application is The provider is not compatible with the version of Oracle client

Before installing the new version of the client, we were running version 11.2 of the client. I ran the OUI installer (19c), I used the "Administrator" option. After the installer completed, I updated the Oracle Path variable to the install location of the new version, as well as the registry entry key at hkey_local_machine/software/oracle/odp.net/[version]. I also ran the script in the folder of the .net dlls in the oracle folder (OraProvCfg.exe) to register it to the gac and that appears to be correct (when I view it in [WINPATH]/assemblies)

Are there any other upgrade gotchas or variables that need to be changed that I'm missing? There are no references to the ODAC version or anything in my machine.config or the web.config of the project.

Comments
Post Details
Added on Jul 17 2020
1 comment
854 views