Skip to Main Content

Upgraded OBP on Ultra 1 - now can't boot

3004Mar 30 2006 — edited Mar 30 2006
Started out wqith an Ultra 1 at OBP 3.5. Upgraded it to Solaris 9. During the install I was offered (but declined) the option to upgrade the firmware to 3.11.

System booted just fine - very happy.

Then in an attack of conscience, I decided to revisit the OBP issue. Downloaded patch 104881-08 from sunsolve, followed the instructions and upgraded OBP to 3.33 (current). Install went fine. Ultra-1/Solaris 9 was listed as a supported platform in the documentation.

Now, however, every time I start the machine, I see this:

Sun Ultra 1 SBus (UltraSPARC???? 167MHz), No Keyboard
OpenBoot 3.33, 128 MB memory installed, Serial #9415477.
Ethernet address 8:0:20:8f:ab:35, Host ID: 808fab35.

(Notice the ??? after UltraSPARC).

When I attempt to boot I see this:

ok boot
Boot device: disk File and args:
krtld: load_exec: fail to expand cpu/$CPU
krtld: error during initial load/link phase
panic - boot: exitto64 returned from client program
Program terminated
ok

The two seem to suggest to me that OBP 3.33 cannnot properly identify the CPU.

Now I have a non-bootable machine with no apparently easy way to revert to an earlier OBP. I have the Solaris 9 12/03 media kit but have not figured out how/if I can somehow get to the embedded 3.11 PROM I was offered earlier.

Has anybody seen this?
Is it a known issue with OBP 3.33? (I notice it purportedly fixed Bugid 1205113: "dev /SUNW,<a href="mailto:UltraSPARC@0" target="_blank">UltraSPARC@0</a>,0" fails. which looks suspiciously like my problem.)

Thanks in advance,

Comments
Post Details
Added on Mar 30 2006
22 comments
194 views