Skip to Main Content

Oracle Developer Tools for Visual Studio

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

update vs2017 community v15.9.49 broke odtforvs2017_193100

User_K7BDTAug 10 2022 — edited Aug 10 2022

Hi
I am connecting to Oracle 19c from EF6. It used to work, till I updated my vs2017.
Now I am getting the following error:
The ADO.NET provider with invariant name 'Oracle.ManagedDataAccess.Client' is either not registered in the machine or application config file, or could not be loaded. See the inner exception for details
I uninstalled and installed odt2017 a few time. Still not working. I did install Oracle.ManagedDataAccess 19.3.1 and Oracle.ManagedDataAccess.Entityframwork 19.3.0 from nuget. As I said. It used to work brilliantly till I update my vs2017.
I also have odac122011 x64 installed. I can connect to Oracle through Toad. My tnsnames.ora are correct.
I also tried to install odac1931 x64, Still getting the above error.

Comments
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Jul 13 2023
Added on Aug 10 2022
6 comments
375 views