Skip to Main Content

Infrastructure Software

Unable to install Oracle Linux 8.6 alongside Windows 11 (new computer)

mathguyNov 1 2022

NOTE: Before I start, I should clarify that I am aware of other options (including WSL, virtual machine, and even dropping Win 11 altogether and installing just Linux). I am not asking about workarounds, I am asking about solving the issue head on.
= = = = = =
My old computer is a Dell desktop which came with Win 10. I had no trouble installing Oracle Linux 7.5 next to it, for dual boot - I have been working on that machine for several years.
I just got a new Dell desktop, preloaded with Win 11. I thought it would be relatively simple to install Oracle Linux 8.6 alongside it, for dual boot. Wishful thinking!
First I made room for Linux on the hard disk. That was no problem. Then I created a full boot/install image on a USB drive (same as I did a few years ago for the older version). I tried two different ways - one was to download the ISO from the Oracle web site and burn it on the USB drive using the instructions from Oracle, on the old machine using Linux (dd command). The other was to download the ISO on the new machine, under Windows, and create the bootable image on USB using Rufus. In both cases the process (detailed below) hangs in exactly the same way and at the same point - so the problem likely lies elsewhere. I am almost certain the image is good - I suspect problems with UEFI and whatnot on the new machine. (Just for kicks, I tried booting the old computer from the same USB drive - that worked without problems. I am able to start a Linux installation from it - I just don't need that on the old computer.)
So - from Windows, I am able to restart the machine with "advanced boot options" or whatever Windows calls it, I select the USB for booting, and I get the first screen with three choices: Install Oracle Linux 8.6, Try and Install ...., and whatever the third option is (probably "start Windows").
I select Install Oracle Linux 8.6 - or Try and Install, I get the same behavior in both cases. At this point, the booting process hangs right away: I get a completely dark screen, with just what looks like a prompt - a single underscore in the top-left corner, not blinking.
The firmware interface is UEFI, and the hard disk uses GUID partition table. Using Rufus, I was asked about these options, and I selected the correct ones. Still, I suspect I am doing something wrong (or I didn't understand something), but I can't figure out what.
Any thoughts? Any info I can add?
Thank you - mathguy

Post Details
Added on Nov 1 2022