Skip to Main Content

Unable to create OEP domain in 12.2.X SOA Quikstart installation

user12944770Jan 20 2016 — edited Feb 12 2016


I am fairly new to Oracle CEP/OEP. But about an year ago.  we did a small POC for one of our use case and thought CEP(11.x) was right fit. Now we wanted take the POC further to start working on a project. Part of which we installed Oracle latest available 12C(12.2.X) SOA in our local machines (Quick installation. of course we use OSB and SOA extensively in all the projects). Our understanding is OEP comes part of SOA installation.  We also see OEP related stuff in our ORACLE_HOME/Middleware folder. I see in JDev , was able to create a OEP application,Project and OEP connection.  However I went in Middleware\Oracle_Home\oep\common\bin and running config.cmd to create OEP domain. That ends up leaving me with the following error.

I tried to see if any one facing similar issue in the internet. yes there are the people but all that they are talking about 12.1 and they end up installing standalone OEP besides SOA installation. I am not sure why would we need a separate OEP installation. They were also telling that this will be fixed in the future release. So We tried 12.2 but still I see the same issue(Not sure if this is fixed). I looked for 12.2 OEP standalone version but there is no such downloadable in the Oracle website but it takes us to "Oracle Stream Explorer"

OEP 12.1.3 installation problem (using quickstart installer)

So now the question

OEP is no longer available as a standalone version?

If so, How to make this work that comes with SOA12c(12.2) installation?

Is this because I did quick installation/Is there any thing explicitly that need to be selected during setup process?

Should we use Stream Explorer which very much like OEP?

Appreciate any help in understanding this and fixing the issue?

Error: A JNI error has occurred, please check your installation and try again

Exception in thread "main" java.lang.NoClassDefFoundError: com/bea/plateng/common/CommonException

        at java.lang.ClassLoader.defineClass1(Native Method)

        at java.lang.ClassLoader.defineClass(






        at Method)


        at java.lang.ClassLoader.loadClass(

        at sun.misc.Launcher$AppClassLoader.loadClass(

        at java.lang.ClassLoader.loadClass(

        at java.lang.Class.getDeclaredMethods0(Native Method)

        at java.lang.Class.privateGetDeclaredMethods(

        at java.lang.Class.privateGetMethodRecursive(

        at java.lang.Class.getMethod0(

        at java.lang.Class.getMethod(

        at sun.launcher.LauncherHelper.validateMainClass(

        at sun.launcher.LauncherHelper.checkAndLoadMain(

Caused by: java.lang.ClassNotFoundException: com.bea.plateng.common.CommonException


        at java.lang.ClassLoader.loadClass(

        at sun.misc.Launcher$AppClassLoader.loadClass(

        at java.lang.ClassLoader.loadClass(

        ... 19 more

Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked due to inactivity on Mar 11 2016
Added on Jan 20 2016