Skip to Main Content

Database Software

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Unable to compile Green-Marl code

Panagiotis KonstantinidisMay 30 2017 — edited Aug 20 2020

Hello all,

I am following this Oracle tutorial, on my Big Data Lite VM 4.7.0.1 (64-bit operating system).

The tutorial has a very simple "Hello World" example to run your first Green-Marl code inside the PGX shell.

The problem is that every time I run p = session.compileProgram("hello_world.gm") I get the following error in the CLI:

06:45:33,575 ERROR Task - >> [ERROR] UnsupportedOperationException on fast-track-analysis-pool: CREATE_ANALYSIS failed

06:45:33,576 ERROR Task - compiler for language GM not found; make sure you have all required GM JAR files on the classpath

java.lang.UnsupportedOperationException: compiler for language GM not found; make sure you have all required GM JAR files on the classpath

  at oracle.pgx.compilers.Compilers.findCompiler(Compilers.java:39)

  ...

I followed the instructions provided on this github page to install the Green Marl compiler, and placed the resulting "gm_comp" executable in /usr/local/bin. I also set my CLASSPATH environment variable to include the jar files in /opt/oracle/oracle-spatial-graph/property_graph/lib/.

I tried explicitly importing the following libraries:

     import oracle.pgx.compilers.Compilers

     import oracle.pgx.compilers.GmCompilation

     import oracle.pgx.compilers.Language

The imports were succesfull but the error was still thrown when running session.compileProgram().

I am using PGX version 2.3.0.

I also read in the tutorial that "Dynamic compilation of Green-Marl code is currently only possible on Linux x86 platforms".

Since I am on a 64-bit system I followed the suggestion of setting the enable_gm_compiler field to false in the PGX configuration file, again without success.

Do you have any idea on how to solve this or what may be the issue?

Thank you in advance.

This post has been answered by Panagiotis Konstantinidis on Jun 8 2017
Jump to Answer
Comments
Post Details
Added on May 30 2017
10 comments
937 views