Skip to Main Content

APEX

Announcement

For appeals, questions and feedback about Oracle Forums, please email oracle-forums-moderators_us@oracle.com. Please ask technical questions in the appropriate category. Thank you!

Theme Roller failing on upgrade to 23.2

Veerendra PatilMay 20 2024 — edited May 20 2024

Hi,

We upgraded from 22.1 to 23.2. Hosted on AWS. All standard apex static images are from CDN.

I clicked on Refresh Theme button after upgrade (in the Shared Components tab - There is a new version of Universal Theme available! You can refresh your theme to take advantage of new features, enhancements, and bug fixes.)

I followed the steps to correctly to refresh the theme after upgrade. - Based on the link here

Below are my styles. I am have created my Custom style out of Vita-Red (Universal Theme.)

When I run the app and open theme roller - I can see that VITA is selected as default and not Custom theme. When I select my Custom Theme Style to set it as default, I get below JS error and I see line - “This theme style doesnot support theme roller Configuration”.

compilerOptions.lessOptions Object
widget.themeRoller.js:428 Uncaught TypeError: Cannot read properties of null (reading 'ratio')
at Object.refreshContrastInfo (widget.themeRoller.js:428:94)
at Object.init (widget.themeRoller.js:489:34)
at q.<computed>.<computed>._callPropertyInit (widget.propertyEditor.js:2145:53)
at a.<computed> [as _callPropertyInit] (desktop_all.min.js?v=23.2.6:31:2889)
at q.<computed>.<computed>.refresh (widget.propertyEditor.js:2692:20)
at a.<computed> [as refresh] (desktop_all.min.js?v=23.2.6:31:2889)
at q.<computed>.<computed>._setOption (widget.propertyEditor.js:2131:20)
at a.<computed> [as _setOption] (desktop_all.min.js?v=23.2.6:31:2889)
at q.<computed>.<computed>._setOptions (desktop_all.min.js?v=23.2.6:31:6097)
at q.<computed>.<computed>.option (desktop_all.min.js?v=23.2.6:31:6032)

I had followed the same steps when we had migrated from 21.2 to 22.1 earlier. It had worked perfect.

I had taken a backup of my app before refreshing Theme after upgrade. It fails there as well with the same error when I try to select my Custom Style.

Please suggest.

Thanks,

Veerendra.

Comments
Post Details
Added on May 20 2024
1 comment
83 views