Skip to Main Content

ODP.NET

Announcement

For appeals, questions and feedback about Oracle Forums, please email oracle-forums-moderators_us@oracle.com. Technical questions should be asked in the appropriate category. Thank you!

Interested in getting your voice heard by members of the Developer Marketing team at Oracle? Check out this post for AppDev or this post for AI focus group information.

The provider is not compatible with the version of Oracle client for ASP.net

2677817Dec 24 2015 — edited Dec 28 2015

We Just upgraded the Oracle client on a dev web server from 11.1.0 to 11.2.0.24 and now we get this error from our ASP.Net web applications:

Oracle.DataAccess.Client.OracleException: The provider is not compatible with the version of Oracle client at Oracle.DataAccess.Client.OracleInit.Initialize() at Oracle.DataAccess.Client.OracleClientFactory..cctor()

I ran a client application on that server and it worked fine so this appears to be an IIS or ASP.Net issue.  We are using the Microsoft Enterprise Library to create the database connection so there is no direct reference to the ODP.Net client.

Does anyone know how to fix this?

This post has been answered by 2677817 on Dec 28 2015
Jump to Answer
Comments
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Jan 25 2016
Added on Dec 24 2015
4 comments
17,737 views