Skip to Main Content

APEX

Announcement

For appeals, questions and feedback about Oracle Forums, please email oracle-forums-moderators_us@oracle.com. Please ask technical questions in the appropriate category. Thank you!

Strange Item Formatting

Alex TMay 8 2024

We recently upgraded to 23.1 patch set 6 (To match the AWS Version) and have started to see a strange issue where the format masking when adding on the item doesn't seem to use the NLS Settings.

We change the NLS Currency on load of the application to £ using ALTER SESSION SET NLS_CURRENCY = "£"

When adding FML999G999G999G999G990D00 format on a item, it formats the it to use a $ i.e $1,2345.00 when it should be £1,2345.00.

The strange thing is that when you set the format mask via SQL/PLSQL in a load process or in a classic/interactive report using TO_CHAR(12345, ‘FML999G999G999G999G990D00’) it works correctly.

Also when adding the format mask to a report column it doesn't do anything to the format (Am i going mad with this one?)

We have also managed to replicate this on apex.oracle.com - https://apex.oracle.com/pls/apex/r/alex_radapex/nls-format-issue/

Can anyone help. We have also tried setting the NLS territory instead and its still the same.

Thanks in advance.

This post has been answered by Karel Ekema on May 8 2024
Jump to Answer
Comments
Post Details
Added on May 8 2024
7 comments
272 views