Skip to Main Content

Developer Community

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

SSL transport detected invalid or obsolete server certificate when using Node oracledb

ckantzerFeb 2 2024

Hello,

I am trying to update my Node.js application to use TLS when connecting to our Oracle 19c DB, but I'm getting the 'SSL transport detected invalid or obsolete server certificate' error.

I'm able to connect successfully using TLS with the same wallet file using sql developer so I know the cwallet.sso file, user, connection string, port, etc are valid. I've tried various combinations of the oracledb library and oracle client but I still get this error.

Are the versions I'm using below incompatible?

Oracle DB: 19c

Oracle client: instantclient-basiclite-windows.x64-19.21.0.0.0dbru

package.json: "oracledb": "^5.5.0"

Connection String: tcps://db.host.name.com:2484/dbservicename?wallet_location=C:/folder_to_wallet/wallet&retry_count=20&retry_delay=3

Thanks,

Chris

Comments
Post Details
Added on Feb 2 2024
0 comments
90 views