Skip to Main Content

SQL Developer

SQL Developer can't read files from the /Users/<user name>/Documents folder in Mac OS

JKLNov 6 2020 — edited Nov 6 2020

I am at a lost and I need some help. I download the latest SQL Developer for Mac, explode the .zip file and I have the file (well, folder technically in Mac). I then Copy and Paste this into my Application directory and start up the app. Everything runs fine until when I try to open my .sql files or anything in my /Users/<username>/Documents folder.
I know that Mac OS Catalina has new security model where you suppose to grand access to the Documents or Download folder by app. But my previous version runs just fine without this setup. Also, I have tried to grant SQL Developer Full Disk access in the security setting and it is still not working. When I select File -> File Open and then click on the /Users/<user name>/Documents folder, I am getting the following error message:
I/O error:
The directory /Users/<user name>/Documents is not accessible. Please select a different directory.
The strange thing is that I can select files from the /Applications folder or anywhere else except my own user document folder.
I have even tried to grand the JDK java program full disk access and it is still not working properly.
I also have the same issue with the Oracle DataModeler app as well.
Has anyone seen something like this? Any help is greatly appreciated. Thanks in advance.

This post has been answered by Ray007 on Nov 24 2020
Jump to Answer
Post Details
Added on Nov 6 2020