Skip to Main Content

GoldenGate

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Some records missed to replicate

Muhammad NazirNov 1 2023

I have following OGG configuration:

Source
emp table:- 50 records
students table:- 2801 records
courses table:- 831 records
teachers table:- 901 records

Target
emp table:- 50 records
students table:- 2801 records
courses table:- 831 records
teachers table:- 901 records

I initiated 2 sessions on "Source". From Session-1 I started a load of 36 records in "emp" table and 100 records in each students, teachers and courses table. While these inserts were in progress I sent a "reboot" signal on “Target” server. By the time "Target" server rebooted the insertion got completed and of course the Pump process was abended. Then I started up GG processes on Target and restarted Pump process on Source. Then I see all the tables started to sync up but later I found except the "teachers" table all tables got synced:

Source
emp table:- 86 records
students table:- 2901 records
courses table:- 931 records
teachers table:- 1001 records

Target
emp table:- 86 records
students table:- 2901 records
courses table:- 931 records
teachers table:- 901 records <<<<====== Missing 100 records.

Then I again loaded 100 records in each students, teachers and courses table and now the sync status is:

Source
emp table:- 86 records
students table:- 3001 records
courses table:- 1031 records
teachers table:- 1101 records

Target
emp table:- 86 records
students table:- 3001 records
courses table:- 1031 records
teachers table:- 1001 records <<<<====== Still missing 100 records.

Can anyone suggest how I can troubleshoot which 100 records are missing in "teachers" table and how they can be brought into the Target?

Comments
Post Details
Added on Nov 1 2023
1 comment
158 views