Skip to Main Content

Solaris Studio 12.4 beta not starting up properly

User12244601-OracleMay 15 2014 — edited Jun 5 2014

Hi all. I installed the 12.4 beta by untarring the download into my own user directory.  When I run the sunstudio command to bring up the IDE, the IDE's splash screen comes up and indicates that it's loading modules.  About 1/4 or so of the way through, the progress bar freezes up for a few seconds, then the splash screen disappears and nothing further ever happens.

Prior to installing this, I was on JRE jre1.6.0_21, but after the 12.4 IDE reported that it only works under Java 7 and later, I installed JRE jre1.8.0_05.  Run the sunstudio command, I saw some command-line warnings about changes in some arcane Java switches, then the splash screen appeared, the progress bar froze up as described, then disappeared and nothing happened.  So I installed JRE jre1.7.0_55 on my machine and tried it.  It didn't complain about the arcane Java switches, but the behavior of the splash screen freezing up 1/4 of the way through loading modules, then disappearing, was identical.

Is there some command line option I should be passing in to result in some kind of diagnostic file that will tell us what's going on here?

Has anyone seen this behavior before and have a solution or workaround suggestions?

The machine is Solaris 10 for SPARC on a Sunblade 2000.  A week or so ago I upgraded the machine from a very old (ca. 2005-2006) version of Solaris 10 to the version that was current as of earlier this year, plus the very latest and greatest kernel patch.

Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked due to inactivity on Jul 3 2014
Added on May 15 2014