Skip to Main Content

Solaris 11.4 Installation Error

runner105Jun 29 2022

I'm running into an issue while trying to install Solaris 11.4. I have created a USB installer drive by downloading the 11.4.0 GA USB Text Installer file. I have tried flashing the .usb file to the drive using both Rufus and Etcher. Both methods created bootable drives, but neither have led to a successful installation. I have tried to use the install disk on multiple PCs and I have tried multiple USB drives, but none were successful.
Now, for the issue itself... The installer drive boots and allows me to run through the entire setup process, choosing target drives, creating user accounts, etc. After starting the installation to the hard drive, the progress bar will reach 99% and read "generate-sc-profile completed". This screen will remain for about 10 minutes before eventually cutting back to a screen that reads "The installation did not complete normally".
I have attached a picture of the resulting log file to this post. It claims that there is not enough space, which I believe to be an issue with the swap size. The swap partition on the USB drive is only around 800MB large and the target system has 8GB of RAM. Do I need to increase the swap size on the live USB? If so, how do I increase it? I also see a line in the log file that says I can add a "--no-backup-be" parameter to skip this step altogether. What do I add this parameter to and how do I do so?
About 2 years ago I installed Solaris to a very similar computer and it worked immediately. I downloaded the exact same file, but am not sure if I used the same methods to flash it to a USB device. Any help is much appreciated, and I apologize if any part of the issue is unclear.
IMG_20220629_105321524.jpg

This post has been answered by runner105 on Aug 30 2022
Jump to Answer
Comments
Post Details
Added on Jun 29 2022
7 comments
115 views