Skip to Main Content

SGD can't seem to login to Unix application server, login dialog keeps popping up

Jan-OracleMay 14 2019 — edited May 14 2019

When SGD tries to launch an application on a Unix application server, it usually tries to connect with ssh -X to the application server. Under certain circumstances the ssh connection can take a long time, which results in the connection attempt from SGD timing out. Most likely this is due to a faulty DNS configuration on the application server and sshd using UseDNS yes, which is the default.

# SGD_SERVER=<FQDN of SGD server>

# for server in $(awk '/^nameserver/{print $2}' /etc/resolv.conf)

do

    echo "${server} $(dig +short ${SGD_SERVER} @${server})"

done

192.0.2.1 ;; connection timed out; no servers could be reached

152.68.154.3 10.150.6.249

10.237.18.52 10.150.6.249

10.254.202.139 ;; connection timed out; no servers could be reached

Changing the order of the name servers in /etc/resolv.conf or commenting out the unresponsive name servers solves this issue. Alternatively one can disable DNS for sshd by editing /etc/ssh/sshd_config and specifying UseDNS no.

Comments
Post Details
Added on May 14 2019
0 comments
26 views