Skip to Main Content

General Development Discussions

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Setting Up a WebLogic Server Instance as a Windows Service

Zeeshan FazalFeb 19 2024

Hi!

I have the Windows 10 and the installed Web logic 12.2.1. I try to set up an Administration Server and a Managed Server to run as Windows services, with follow instruction: [http://docs.oracle.com/cd/E12840_01/wls/docs103/server_start/winservice.html] .

Configuring ‘’ Requiring Managed Servers to Start After Administration Servers ‘’
First i try to set up the WebLogic as service.
For its i maked the server-specific script:

SETLOCAL
set DOMAIN_NAME=base_domain
set USERDOMAIN_HOME=C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain
set SERVER_NAME=AdminServer
set WL_HOME=C:\Oracle\Middleware\Oracle_Home\wlserver
set PRODUCTION_MODE=true
set WLS_USER=weblogic
set WLS_PW=zeeshan123
set MEM_ARGS=-Xms128m -Xmx512m
call "C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain\bin\setDomainEnv.cmd"
call "C:\Oracle\Middleware\Oracle_Home\wlserver\server\bin\installSvc.cmd"
ENDLOCAL

With this batch file i make the new Windows Service, all of the services executed successfully and confirmed from http://localhost:7001/console, then connect to report by starting Namingservice.bat 14021 by executing the instruction

C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain\reports\bin\namingservice.bat 14021

and is show me messages of successfully started but when i conformed the status from link localhost:9002/reports/rwservlet/getserverinfo, its neither show me status nor show me report from my application.

Please help me out.

Comments
Post Details
Added on Feb 19 2024
0 comments
59 views