Skip to Main Content

SQLcl

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Run large data export script

Earl LewisNov 18 2022

I'm having trouble running a large schema export script (~.5M lines), generated with SQL Developer Data Export. I'm trying to move a schema from one instance to another and don't have access to data pump on the source side so can't use that.
I've tried to run the script in SQL Developer and it just hangs after about 10 commands in. And also tried running it as a script file in SQLcl. The weird part of the SQLcl run is that I can see that the views got created, but almost nothing else (no packages, procedures, functions, tables).
I added "set termout off" to the top of the file before I ran it, so hopefully it would help on the I/O side of things but somewhere along the way this failed (apparently) and not sure why, or how to fix it, besides trying to break the script up into smaller chunks, which I'm loathe to do.
Any suggestions for running these really large export scripts in SQLcl?

This post has been answered by Earl Lewis on Dec 2 2022
Jump to Answer
Comments
Post Details
Added on Nov 18 2022
5 comments
107 views