Skip to Main Content

Java APIs

problems with distributing java applciation

898268Nov 6 2011 — edited Nov 7 2011

I'm having some problems which I hope you could help me with. I just finished my first desktop application in netbeans, and now I would like tot est it on another computer. The application uses also other .jar files (libraries). I found some instructions on the internet on how to make an executable .jar file, and I did it. The file is now on my computer. Then I zipped myApp.jar and the ldirectory lib, where other .jar files are located and unzipped this into a folder on another PC.

On my computer it runs properly. If I run it from cmd with the command java -jar myApp.jar, it works and it also works if i double click the myApp.jar file. But it doesnt work on another PC. I checked the java version, it wasn't ok so I updated it, but it still doesnt work. In task manager I can see that when I run the file, for approximatly 30 seconds the javaw.exe appears like the program is trying to run, but then it dissappears, like something went wrong.

Here is the manifest, which is in myApp.jar file:

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.8.1
Created-By: 1.6.0_22-b04 (Sun Microsystems Inc.)
Main-Class: virtcomui.VirtcomGUIOsnova
Class-Path: lib/beansbinding-1.2.1.jar lib/jcalendar-1.4.jar lib/mysql
-connector-java-5.1.17-bin.jar lib/sqljdbc4.jar lib/edtftpj.jar lib/l
X-COMMENT: Main-Class will be added automatically by build

What am I doing worng? I woudl like it to start running on just a double-clicl, so it is friendly to the user (no using of command prompt or thigs like that).

Thans for the help.
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Dec 5 2011
Added on Nov 6 2011