Skip to Main Content

Problem installing Oracle Linux 9 on Virtual Machine in ESXi

User_CWVNCJan 12 2023

I am exploring OL9 as a possible replacement for CentOS, but already having trouble simply installing. I read through the versions, and decided on the Unbreakable Kernel, and downloaded the ISO to my ESXi server. I created a VM and launched it, and the installation started. I selected "Test this media and Install Oracle Linux 9.1.0" and the VM booted into the installation menu.
Obviously, it won't let me proceed without entering all items marked with an orange alert triangle. I can enter and clear all of them except for "Installation Source" which starts with a subheading of "Error setting up base repository", and "Software Selection - Installation source not set up".
The "Installation Source" has a question, "Which Installation Source would you like to use" with two choices: "Auto Detected Installation Media" and "On the network". Since I downloaded the ISO and mounted it as a CD/DVD, and I see the installation has recognized the SR0 device, I chose "Auto Detected Installation Media" and click the "Verify" button. A new window pops up saying, "Media Verification", then a moment later it says, "This media is good to install from", with a single choice of, "OK". however when I select "Done" and return to the installation screen it returns to an orange alert triangle: "Installation Source - setting up Installation Source..." until ultimately it fails (?) with "Error setting up base repository".
I've even tried a text-based installation, but nothing I do seems to clear the Orange Alert Triangle. I have to admit this isn't a good first impression of Oracle Linux. Is the ISO I downloaded not actually capable of installing the product? If not, why does the installation test the media and tell me it verifies and is good to install from, and what did I download? What else do I need to do to actually get a working install and test out OL9 in a VM?
Ideas? Thoughts? What is going wrong?

Post Details
Added on Jan 12 2023
1 comment