Skip to Main Content

Please help me to debug a bug for instant client on linux x86-64

2726432Aug 5 2014 — edited Aug 7 2014

I am a c junior programmer, I wrote a c demo based on <Call Interface Programmer's Guide>,but i found failed sometimes and successful somtimes when i run my demo on linux x86-64.

I wondered why it was failed sometimes and successful sometimes, so i used command strace to debug my demo.

I found my demo was failed when called function getsockopt  whose third argument was negative. The following code:

getsockopt  (5, SOL_SOCKET, SO_SNDBUF, [-8683868481690533888], [4]) = 0

my demo run successful when the third argument of function getsockopt was positive.The following code:

getsockopt(5, SOL_SOCKET, SO_SNDBUF, [4636081913715490816], [4]) = 0

I downloaded rpm package of instant client for linux x86-32 and installed, the same demo worked perfectly on linux x86-32.

Did instant client for linux x86-64 has a bug?

any advise would be great.

Thank you!

This post has been answered by Janitor-Oracle on Aug 7 2014
Jump to Answer
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked due to inactivity on Sep 4 2014
Added on Aug 5 2014