Skip to Main Content

Cloud Platform

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

PHP not working in the OCI instance (Oracle Linux)

andreitc-OracleAug 25 2022

Hi,

I have an oci instance and I'm trying to create a website on it from this tutorial right here:
https://docs.oracle.com/en-us/iaas/developer-tutorials/tutorials/apache-on-oracle-linux/01-summary.htm
Everything worked ok, until the first step from Install and Configure Apache and PHP, which is

sudo yum install -y oracle-php-release-el7
This doesn't work saying that:

No match for argument: oracle-php-release-el7
Error: Unable to find a match: oracle-php-release-el7

I skipped that step and installed php and if I do php -v, my php version is printed out:

[root@finsvm-oel fin]# php -v
PHP 7.2.24 (cli) (built: Oct 22 2019 08:28:36) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
[root@finsvm-oel fin]#

Which should mean that php is installed.
However, when I reach the final step:

  1. In the file, input the following text and save the file:
    <?php
    phpinfo();
    ?>

And try to access this file that i created, i get an error in the browser:
Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

With any other file html file it is working, I am able to see it's content on the browser.
However, on any php file, I get this error.
What am I doing wrong? Does it have something to do with the fact that that package is no longer available, and if so how can I solve this?

Thanks,
Andrei

Comments
Post Details
Added on Aug 25 2022
4 comments
269 views