Skip to Main Content

PageFlow based portlet not rendering content

vali_nedelcu-JavaNetSep 15 2008 — edited Sep 26 2008
Hello everybody,

I'm trying to use a page flow as a source for a portlet.
Unfortunately the portlet content is not rendered; instead, just the portlet window with the title bar is present.
(No error message is present on either the console or the server log.)

The PageFlow is a trivial one -- containing just the begin action and the index.jsp file (faces). I was able to test the pageflow directly from Workshop (choosing the `*Run on Server..*` menu action). The index.jsp content was rendered as expected. But when I tried the URLs for the portal or the portlet, no content was rendered!

Perhaps a sketch can explain better what I'm experiencing:

Request for `dummy JPF` URL ----------------------> content rendered (as expected)
Request for Portlet with `dummy JPF` URL ----------------------> NO content rendered (+unexpected+)

I tried the combinations: WebLogic Portal 10.2 + Workspace Studio 1.1 and WebLogicPortal 10.0 + Workshop for Weblogic Platform with the same result.

What is the problem?! Has anyone ever experienced something similar?
(According to the [BEA Portlet Dev docs|], using a PageFlow as a source for a portlet is a perfectly good option.)
Post Details
Added on Sep 15 2008