Skip to Main Content

OVM Server Pool cannot see its Repository

Alfred_AnnanMar 30 2019 — edited Apr 1 2019

Hello Guys,

Our OVM system comprises an OVM Manager running on a separate server, two (2) twin HP machines as OVM Servers namely ovmsrv01 and ovmsrv02 and a FreeNAS storage of 37TB. The storage is seen by the OVM as a LUN of 25TB called FreeNAS (1) and 15TB for NFS volume also called nsfstore pointing to two shares.

Everything was working smoothly, until a week ago when the SATADOM on the FreeNAS Storage failed. We got a replacement SATADOM drive and were able to boot up the storage and get it working again.

However, the OVM platform could not recognise the FreeNAS (1) LUN and after re-discovery it created a new LUN LINK called FreeNAS (2). From that point on nothing has worked right any more.

As the repository reported missing, then it appeared after a few restart and re-discovery and then the NFS drive could not be recognized then after a discovery and restart it appeared.

Currently, the cluster is DOWN for the previous Server Pool called ovmsrvpool01 and recognizing that the repository was intact I created a new server Pool srvpool01 and move the two servers into the new pool. This worked, but now I cannot present the Repository to this new Pool since when in trying to release Ownership from the old pool it fails with error:

OVMAPI_7262E Unable to find an owned and running server to perform release Ownership operation on ovmrepo01. Reasons: [Sat Mar 30 17:17:34 GMT 2019]

Any Ideas and pointers as to how to resolve this and any tools I can use to discover what is even wrong with the initial LUN name change and how to correct it will be welcomed.

Thanks

Alfred

Comments
Post Details
Added on Mar 30 2019
1 comment
120 views