Skip to Main Content

OVM Manager Upgrade from 3.3.4 to 3.4.5 fails

2986254Feb 13 2019 — edited Feb 18 2019

I have been trying to upgrade OVM Manager 3.3.4 to 3.4 5 and have been having an issue.

It runs fine until this Point.

Retrieving Oracle VM Manager CLI tool ...

Extracting Oracle VM Manager CLI tool...

Installing Oracle VM Manager CLI tool ...

At this point it seems from the Log that the weblogic AdminServer is stopped and then a restart is tried (and fails)

The reason is that it get permission denied when trying to access _WLS_ADMINSERVER000000.DAT

/u01/app/oracle/ovm-manager-3/domains/ovm_domain/servers/AdminServer/data/store/default/_WLS_ADMINSERVER000000.DAT

Permissions are :

-rw-r-----. 1 oracle dba 1049088 Feb 13 15:30 _WLS_ADMINSERVER000000.DAT

If I remove this file and then manually as oracle run /u01/app/oracle/ovm-manager-3/domains/ovm_domain/startWebLogic.sh the WebLogic AdminServer starts and the upgrade continues until the point where the OVM Server is tried to be started.

Shutting down Oracle VM Manager instance ...

Starting Oracle VM Manager instance ...

I then killed the AdminServer that was running on my shell session and found that I had to again delete the _WLS_ADMINSERVER000000.DAT file.

After this starting the ovmm service allowed the Upgrade to continue to the end.

The OVM Manager web console seems fine, it can see the OVM Servers in the cluster and the VMs running on them, However I am not 100% sure that the upgrade is good as this has been done adhoc.

Does anyone know any reasons for the _WLS_ADMINSERVER000000.DAT file to show permission denied, preventing the weblogic AdminServer to fail to start?

Stopping and Starting the OVMM Server causes the same issue and the file needs to be deleted again before it can be started properly

####<2019-02-13T16:48:38.512+0000> <Error> <Store> <hostname.domain> <AdminServer> <[STANDBY] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1550076518512> <BEA-280061> <The store "_WLS_AdminServer" could not be deployed: weblogic.store.PersistentStoreFatalException: [Store:280105]The persistent file store "_WLS_AdminServer" cannot open file _WLS_ADMINSERVER000000.DAT.

weblogic.store.PersistentStoreFatalException: [Store:280105]The persistent file store "_WLS_AdminServer" cannot open file _WLS_ADMINSERVER000000.DAT.

Comments
Post Details
Added on Feb 13 2019
1 comment
221 views