Skip to Main Content

oraopmnperf.dll

Mr.LeoMay 15 2020 — edited May 19 2020

Hello, folks.

Well, I don't even know by where to start. My config:

Windows 2019

Oracle DB 19.0

Cloud Control 13.4

There's been three days I'm battling with the Cloud Control installer, and I'm losing big time.  Not only the thing is extremely slow (and I scrap/create the database anew for each retry), I can't get past the famous 80% error - BI Publisher Configuration:

pastedImage_0.png

I found some references about it, but each one point to different versions and problems.  None fit my case, though.

After cancelling it, I try starting the service manually anyway.  It seems installed, just the BI part is not configured.  But emctl does not start the webtier correctly:

pastedImage_1.png

Let's see the the costmary logs:

<DOMAIN_HOME>/system_components/ohs/ohs_nm.log

 

<2020-05-14 18:37:06> <INFO> <OHS-0> <Domain initialized for C:\Oracle\gc_inst\user_projects\domains\GCDomain>

<2020-05-14 18:37:06> <INFO> <OHS-4112> <Creating instance ohs1>

<2020-05-14 19:02:04> <INFO> <OHS-4114> <Updating instance ohs1>

<2020-05-14 19:05:38> <INFO> <OHS-0> <Domain initialized for C:\Oracle\gc_inst\user_projects\domains\GCDomain>

<2020-05-14 19:10:17> <INFO> <OHS-4018> <Starting server ohs1>

<2020-05-14 19:10:17> <INFO> <OHS-0> <Running C:\Oracle\cloudcontrol\ohs\bin\launch.exe C:\Oracle\cloudcontrol\ohs\bin\httpd.exe -DOHS_MPM_WINNT -d C:/Oracle/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1 -f C:\Oracle\gc_inst\user_projects\domains\GCDomain\config\fmwconfig\components\OHS\instances\ohs1\httpd.conf>

<2020-05-14 19:10:20> <INFO> <OHS-0> <httpd.exe: Syntax error on line 67 of C:/Oracle/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1/httpd.conf: Cannot load C:/Oracle/cloudcontrol/ohs/modules/mod_ora_audit.so into server: The specified module could not be found.  >

<2020-05-14 19:10:21> <SEVERE> <OHS-0> <C:\Oracle\cloudcontrol\ohs\bin\launch.exe C:\Oracle\cloudcontrol\ohs\bin\httpd.exe -DOHS_MPM_WINNT -d C:/Oracle/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1 -f C:\Oracle\gc_inst\user_projects\domains\GCDomain\config\fmwconfig\components\OHS\instances\ohs1\httpd.conf: exit status = 1>

<2020-05-14 19:10:21> <INFO> <OHS-4005> <Check the instance log file for more information: C:\Oracle\gc_inst\user_projects\domains\GCDomain\servers\ohs1\logs\ohs1.log>

<2020-05-14 19:10:21> <SEVERE> <OHS-0> <Failed to start the server ohs1>

The last line shows the famous "Failed to start the server ohs1", but gives no explanation wyh.

The <DOMAIN_HOME>/nodemanager/nodemanager.log

<14-May-2020 7:10:17 o'clock PM EDT> <INFO> <GCDomain> <BIP> <The server 'BIP' is running now.>

<14-May-2020 7:10:17 o'clock PM EDT> <INFO> <GCDomain> <ohs1> <Creating directory "C:\Oracle\gc_inst\user_projects\domains\GCDomain\system_components\OHS\ohs1\logs">

<14-May-2020 7:10:17 o'clock PM EDT> <INFO> <GCDomain> <ohs1> <Creating directory "C:\Oracle\gc_inst\user_projects\domains\GCDomain\system_components\OHS\ohs1\security">

<14-May-2020 7:10:17 o'clock PM EDT> <INFO> <GCDomain> <ohs1> <Creating directory "C:\Oracle\gc_inst\user_projects\domains\GCDomain\system_components\OHS\ohs1\tmp">

<14-May-2020 7:10:21 o'clock PM EDT> <WARNING> <Server start command for OHS server 'ohs1' failed due to: [Failed to start the server ohs1

Check log file C:\Oracle\gc_inst\user_projects\domains\GCDomain\system_components\OHS\ohs_nm.log]. Please check Node Manager log and/or server 'ohs1' log for detailed information.>

<14-May-2020 8:41:21 o'clock PM EDT> <INFO> <GCDomain> <BIP> <The server 'BIP' with process id 96 is no longer alive; waiting for the process to die.>

<14-May-2020 8:41:21 o'clock PM EDT> <INFO> <GCDomain> <BIP> <Server was killed>

Once more the "Failed to start the server" message.  Still doesn't say much about the problem.

Curiously, I found this in <DOMAIN_HOME>\servers\ohs1/logs/lastinvocation.log

@ECHO OFF

SETLOCAL

SET PATH=C:\Oracle\cloudcontrol\ohs\bin;c:\Oracle\CLOUDC~1\bin;c:\Oracle\CLOUDC~1\oracle_common\bin;C:\Windows;C:\Windows\system32\

SET SystemDrive=C:

SET PRODUCT_HOME=C:/Oracle/cloudcontrol/ohs

SET COMPONENT_TYPE=OHS

SET COMPONENT_LOG_PATH=C:/Oracle/gc_inst/user_projects/domains/GCDomain/servers/ohs1/logs

SET NLS_LANG=AMERICAN_AMERICA.WE8ISO8859P1

SET ORA_NLS33=c:\Oracle\CLOUDC~1\nls\data

SET SHELL=cmd.exe

SET COMPONENT_CONFIG_PATH=C:/Oracle/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1

SET SystemRoot=C:\Windows

SET COMMON_COMPONENTS_HOME=c:\Oracle\CLOUDC~1\oracle_common

SET ORACLE_INSTANCE=C:/Oracle/gc_inst/user_projects/domains/GCDomain

SET ComSpec=C:\Windows\system32\cmd.exe

SET LANG=en_IN.utf8

SET ORACLE_HOME=c:\Oracle\CLOUDC~1

SET COMPONENT_NODEMANAGER_STATE_FILE=C:/Oracle/gc_inst/user_projects/domains/GCDomain/servers/ohs1/logs/ohs.state

SET COMPONENT_NAME=ohs1

C:\Oracle\cloudcontrol\ohs\bin\launch.exe C:\Oracle\cloudcontrol\ohs\bin\httpd.exe -DOHS_MPM_WINNT -d C:/Oracle/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1 -f C:\Oracle\gc_inst\user_projects\domains\GCDomain\config\fmwconfig\components\OHS\instances\ohs1\httpd.conf

So, the last thing to be run was that launch.exe?  OK, let me run it manually from a prompt to see if it gives me a hint.  And it did:

pastedImage_10.png

And here is the title of this question.  oraopmnperf.ddl?  Google did not help me here, there are only a couple of fake entries with this term that say absolutely nothing about it.

There is an Oracle entry in the results, but that page talk about another ddl, oraiau.dll :

https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=421459787638417&parent=EXTERNAL_SEARCH&sourceId=PROBLEM&…

Accordingly to it, the oraiau.dll missing is due to a missing Visual C++ Redistributable package.

I didn't believe it had anything to do with my problem, but I installed several C++ packages - 2008, 2012, 2015, 2017, 2019 - without luck.  The error persists.

Then I found this page that perfectly describes the situation and match every single log entry I have (although mentions nothing about this dll):

https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=419834448938944&parent=EXTERNAL_SEARCH&sourceId=PROBLEM&…

The only thing is that this is for a Linux environment.  It points to a libclntshcore.so.12.1 file that does not exists in a Windows environment.

In fact, most of (if not all) problems and solutions I found was in a Linux env.  The rarely mentions I found for Windows env were in the doc, which does not really help when troubleshooting.


So folks, can anybody shed some light on this?  Have you ever heard about this missing ddl? What exactly it is where can I find/install it?


Comments
Post Details
Added on May 15 2020
7 comments
544 views