Skip to Main Content

LiveLabs & Workshops

Oracle LiveLabs Question

User_PRZB8Dec 25 2020

Hi there,
I am working on the Oracle 'Building Microservices with Oracle Converged Database' LiveLab/Workshop:
In Lab 1 Step 2, the instructions say to download the workshop source code using the below command:
Screen Shot 2020-12-25 at 5.49.24 PM.png
When I enter this command I get the following error:

End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of or, and cannot find, period.

In order to troubleshoot, I entered only the curl command to download the zip file. Then entered the command 'file' and saw that is not actually a zip file.
Upon navigating to the URL where the is being downloaded from I get the following error:
{"code":"BucketNotFound","message":"Either the bucket named 'msdataworkshop' does not exist in the namespace 'stevengreenberginc' or you are not authorized to access it"}
I am wondering if there is something wrong with the URL/location where the is being dowloaded from. I tried chatting support within the OCI dashboard but they also received the same error upon navigating to the URL. They suggested posting the issue here.
I really appreciate any support that can be provided on this!
Thank you so much! - Kiana

This post has been answered by Pparkins-Oracle on Jan 4 2021
Jump to Answer
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Feb 1 2021
Added on Dec 25 2020