Skip to Main Content

Security Software

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Oracle freeipa 4.2 installation unable to find javac compilier

Pojen HuangJan 10 2024

I am trying to set up freeipa in my home lab using the guide: https://docs.oracle.com/en/learn/ol-freeipa/#introduction

After execute “ipa-server-install”, it always failed at:

Done configuring directory server (dirsrv).
Configuring Kerberos KDC (krb5kdc)
[1/10]: adding kerberos container to the directory
[2/10]: configuring KDC
[3/10]: initialize kerberos container
[4/10]: adding default ACIs
[5/10]: creating a keytab for the directory
[6/10]: creating a keytab for the machine
[7/10]: adding the password extension to the directory
[8/10]: creating anonymous principal
[9/10]: starting the KDC
[10/10]: configuring KDC to start on boot
Done configuring Kerberos KDC (krb5kdc).
Configuring kadmin
[1/2]: starting kadmin
[2/2]: configuring kadmin to start on boot
Done configuring kadmin.
Configuring ipa-custodia
[1/5]: Making sure custodia container exists
[2/5]: Generating ipa-custodia config file
[3/5]: Generating ipa-custodia keys
[4/5]: starting ipa-custodia
[5/5]: configuring ipa-custodia to start on boot
Done configuring ipa-custodia.
Configuring certificate server (pki-tomcatd). Estimated time: 3 minutes
[1/29]: configuring certificate server instance
Failed to configure CA instance
See the installation logs and the following files/directories for more information:
/var/log/pki/pki-tomcat
[error] RuntimeError: CA configuration failed.
CA configuration failed.
The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information
[root@ipa jre]#

When check the /var/log/pki/pki-tomcat/localhost.2024-01-09.log

09-Jan-2024 21:30:06.818 SEVERE [https-jsse-nio-8443-exec-1] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [jsp] in context with path [] threw exception [org.apache.jasper.JasperException: Unable to compile class for JSP] with root cause
Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.392.b08-4.0.1.el8.x86_64/jre"
at org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCompiler(CompilerAdapterFactory.java:132)

It says it can't find javac. I confirmed if I just use the instruction above, it doesn't have javac. I then get a copy of jdk from Oracle and set my JAVA_HOME, but still getting the same javac not found. (As test, I even overwrite the content from the download jdk to the folder that installer is looking for but still get the same error.)

[root@ipa ~]# export JAVA_HOME=/tmp/kk/jdk1.8.0_381/
[root@ipa ~]# ls $JAVA_HOME/bin
appletviewer javadoc jconsole jps orbd servertool
ControlPanel javafxpackager jcontrol jrunscript pack200 tnameserv
extcheck javah jdb jsadebugd policytool unpack200
idlj javap jdeps jstack rmic wsgen
jar javapackager jhat jstat rmid wsimport
jarsigner java-rmi.cgi jinfo jstatd rmiregistry xjc
java javaws jjs keytool schemagen
javac jcmd jmap native2ascii serialver
[root@ipa ~]#

It is not clear to me why it can't find javac to continue with the install.

[root@ipa ~]# cat /etc/oracle-release
Oracle Linux Server release 8.9
[root@ipa ~]# uname -a
Linux ipa.pojencrossing.localdomain 5.15.0-201.135.6.el8uek.x86_64 #2 SMP Thu Nov 30 17:54:37 PST 2023 x86_64 x86_64 x86_64 GNU/Linux
[root@ipa ~]#

Comments
Post Details
Added on Jan 10 2024
2 comments
155 views