Skip to Main Content

Oracle Database Free

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Oracle Free Docker very slow?

Gabriel WernerFeb 27 2024

Hey everyone,

for development we are using the Oracle XE 21c Docker-Image. We version our database with flyway, so we don't export/import data, but we build our DB freshly before we start developing.

Everything is working fine with 21c.

Now i tried changing to the newest 23 Free Docker, building the DB freshly was no problem at all.

The problem came up after working in our application which inserts and selects data. It is using spring data with hibernate in the back and we have some datamodels which include many tables (around 200) when they get persisted (but its not like high amounts of rows being inserted).

With 21 XE an insert or select took few seconds. With 23 free an insert and select take exactly 7 minutes. I also tried to execute the generated statement directly, it doesn't change a thing, so it can't be our application stack (max an unoptimized statement from hibernate). For those 7 minutes the database also is working pretty hard, top (executed inside the docker container) shows ~150-180% CPU-Usage.

Is there a known bug or should i start debugging my statement which obviously runs fine in 21 XE?

I also searched for migration-advice, but couldn't seem to find anything that had a breaking change making stuff act like that.

Thank you in advance!

Comments
Post Details
Added on Feb 27 2024
2 comments
223 views