Skip to Main Content

Java Development Tools

Oracle Enterprise Pack for Eclipse issue - need it to work with JDK 1.7

2903662Mar 13 2015 — edited Aug 15 2015

Please let me know if there's a more appropriate forum - thanks.

I need to install OEPE into Eclipse STS (luna) using JDK 1.7.  I did this 2 months ago without a problem but had to recently reinstall.  I get the error, 'Oracle Enterprise Pack for Eclipse requires Java 8 or higher'.  I need to find the older version of OEPE that works with JDK 1.7.

I saw that the current OEPE installs 'Oracle WebLogic Scripting Tools' and 'Oracle WebLogic Server Tools' with version 7.3.4.  I remember that when I previously (successfully) installed OEPE into STS, the versions for these were 7.3.3.  I googled and found Oracle Enterprise Pack for Eclipse and installed it from there.  I saw that the versions of the above 2 items are now 7.3.3 but ... I still receive the same error.


- STS: Version: 3.6.4.RELEASE  Build Id: 201503100339   Platform: Eclipse Luna SR1 (4.4.2)

- My weblogic install is weblogic 12c

Any help?



Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Sep 12 2015
Added on Mar 13 2015