Skip to Main Content

Database Software

ORA-27101: shared memory realm does not exist while connecting to pdb

jeffhanAug 22 2013 — edited Aug 23 2013

i've install oracle 12c on Redhat 6. The creation of CDB and PDB was all successful.

SQL> select name, open_mode from v$pdbs;

NAME                           OPEN_MODE

------------------------------ ----------

PDB$SEED                       READ ONLY

CMS121P1                       READ WRITE

FUN121P1                       READ WRITE

SQL> select name,con_id from v$active_services;

NAME                                                                 CON_ID

---------------------------------------------------------------- ----------

fun121p1                                                                  4

cms121p1                                                                  3

o121cdbXDB                                                                1

o121cdb                                                                   1

SYS$BACKGROUND                                                            1

SYS$USERS                                                                 1

6 rows selected.

i created myself an user by altering the container and username (jehan)

Now the weird things happened:

1. the CDB or PDB didn't get registered on listener. even i ran

"exec dbms_service.start_service('cms121p1');

i had to manually add the entries for all CDB and PDBs.

2. i can't connect to any of PDB from sqlplus, even they are open&online

bash-4.1$ sqlplus jehan/passwd@localhost:1521/fun121p1

SQL*Plus: Release Production on Thu Aug 22 11:23:28 2013

Copyright (c) 1982, 2013, Oracle.  All rights reserved.


ORA-01034: ORACLE not available

ORA-27101: shared memory realm does not exist

Linux-x86_64 Error: 2: No such file or directory

Process ID: 0

Session ID: 0 Serial number: 0

i used DBCA to wipe off the whole database (CDB&PDB) and recreate them again. still the same results. Anybody runs to the same issue as mine?


This post has been answered by jeffhan on Aug 23 2013
Jump to Answer
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Sep 20 2013
Added on Aug 22 2013