Skip to Main Content

OEPE for Eclipse Mars.1 running on Java 7 desktop?

listen RANJan 12 2016 — edited Jan 12 2016

I am trying to set up an existing WebLogic application in my Eclipse workspace. How can I set up WebLogic 10.3.3 as my server run-time environment?


My Eclipse environment is new, so I have eclipse mars.1. It runs fine on my desktop (JRE7).

After I installed the latest OEPE from http://download.oracle.com/otn_software/oepe/mars I had trouble starting eclipse, because this OEPE needs Java 8. I reverted my eclipse installation and tried to install an older OEPE.

Based on the discussion in Oracle Enterprise Pack for Eclipse issue - need it to work with JDK 1.7, I tried to install the WebLogic Server Tools from OEPE 12.1.3.3.1 at http://download.oracle.com/otn_software/oepe/12.1.3.3.1/luna/repository. The installation fails, but suggests as remediation that I install version 8.5.1.20160107* of the WebLogic Server Tools instead. That version depends on Java 8, so it is not a good option for me.

Probably I would be fine if I installed Java 8 on my desktop, but what would be my best option if I need to stick with Java 7?

Should I use an older version of Eclipse instead of Mars.1?

My desktop WebLogic installation is 10.3.3, and includes jdk1.6 and oepe 11gR1 (with Eclipse Galileo).

Comments
Post Details
Added on Jan 12 2016
6 comments
2,882 views