Skip to Main Content

OCI8 not displaying in phpinfo() [SOLVED]

884377Aug 25 2011 — edited Sep 1 2011
I can't get oci8 to install at all. Here is what I've tried...

1.) checked for duplicate php.ini files (none found)
2.) added instant client files to windows\system32 (did not work)
3.) tried PHP 5.2, 5.3.2 and 5.3.0 (none work)
4.) checked the extension=php_oci8.dll and all other oci dll's were un-commented in my php.ini (all where un-commented)
5.) checked that the .dll's where in the "ext" directory (they are all there)
6.) added to my environment variables ORACLE_HOME with the path to the instantclient directory (did not work)
7.) checked and rechecked that my path variable is set to the right instant client directoy (it is set to the right place)
8.) checked to be sure that the folder had permissions to access from IUSR_ account (checked ok, and added everyone just to be sure. still not working)
9.) un-commented and set "extension_dir" in the php.ini to the directory of my php .dll's (did not work)
10.) rebooted and re-stared IIS or the server a million times. after each environment var change or php.ini change (did not work)
11.) tried 64bit instant client and 32bit instant client (neither worked)
12.) if I try to run sqlplus from the cmd box I get "program is not configured correctly try reinstalling it." Funny thing is that program doesn't even get installed...
13.) Added to my environment vars TNS_ADMIN and the path to the tnsnames.ora file (did not work)
14.) tried to putenv("ORACLE_HOME=<path to instant client>"); (did not work but getenv("ORACLE_HOME") return the right path even when I don't putenv();)

I've never had a problem setting up instant client or oci8 libraries before today...

The server that is giving my trouble is a VPS hosted 64bit windows 2003 server with IIS6. (this server is evil!!)

Any help is appreciated. I would love to get some sleep tonight. I have been working on this problem foe three days now.

Edited by: salt on Aug 31, 2011 3:56 PM

Edited by: salt on Sep 1, 2011 11:14 AM
Post Details
Added on Aug 25 2011