Skip to Main Content

OBIEE Presentation Services for OBIA rpd gets ODBC SQLEnvironment failed

Gareth RobertsNov 7 2008 — edited Nov 26 2008
Hi,



I'm trying to get OBIEE 10.1.3.3.2 services running on applications tier Suse Linux 9 machine for OBIA 7.9.5. I have successfully got OBIEE working on Windows desktop, but need to get the OBIEE Suse server running. I'm running OC4J on the Suse box and its working okay. I copied the EnterpriseBusinessAnalytics.rpd file, setup web/catalog/EnterpriseBusinessAnalytics and NQSServer.INI, plus set ORACLE_HOME and PATH for connectivity to database tier. The directories of the items mentioned below are in PATH and LD_LIBRARY_PATH prior to attempting starting OBIEE (presentation) services via run-sa.sh and run-saw.sh.



I'm getting error messages as follows in sawlog0.log on startup of OBIEE services:



<em>Oracle BI Presentation Services 10.1.3.3.2 (Build 071217.1900) are starting up.

---------------------------------------

Type: Error

Severity: 20

Time: Fri Nov 7 18:24:22 2008

File: project/webodbcaccess/odbcenvironment.cpp Line: 98

Properties: ThreadID-16384

Location:

saw.webextensionbase.staticinit

saw.sawserver



ODBC driver preload failed. ODBC library name: 'libnqsodbc.so'

---------------------------------------

Type: Error

Severity: 20

Time: Fri Nov 7 18:24:22 2008

File: project/webodbcaccess/odbcenvironment.cpp Line: 100

Properties: ThreadID-16384

Location:

saw.webextensionbase.staticinit

saw.sawserver



libnqportable.so: cannot handle TLS data

---------------------------------------

Type: Error

Severity: 42

Time: Fri Nov 7 18:24:22 2008

File: project/webodbcaccess/odbcenvironment.cpp Line: 195

Properties: ThreadID-16384

Location:

saw.webextensionbase.staticinit

saw.sawserver



Allocation of SQLEnvironment failed (SQLError: -1). Please ensure that the odbc driver is in your environment path.</em>





Google'd it and found someone with same problem, but no fix.



Can anyone point me in the right direction?



Thanks,

Gareth
Comments