Skip to Main Content

NLS_LANG prevents sqlci from reading scripts

BG4GRAPHAug 4 2020 — edited Aug 5 2020

Hi,
I am used to configure my environment with NLS_LANG=GERMAN_GERMANY.WE8MSWIN1252, but I noticed that this setting prevents sqlci from reading scripts with @ or start; either I get the error message

oracle.dbtools.raptor.newscriptrunner.ScriptExecutor <init>

SCHWERWIEGEND: URL konnte nicht verarbeitet werden:file:/D:/Entwicklung/NeT_X/svn/ntdc14/source/db/views/v_qualys_associations.sql

Aug 03, 2020 2:53:23 PM oracle.dbtools.raptor.newscriptrunner.ScriptExecutor run

SCHWERWIEGEND: java.io.Reader.<init>(Unknown Source)

java.lang.NullPointerException

or (setting a detailed file url explicitly) I get no feedback at all, the script is not executed.

Meanwhile I found that sqlci excpects to be configured by statements like JAVA_TOOL_OPTIONS='-Duser.region=DE -Dfile.encoding=windows-1251' (by the way: the setting -Duser.language=de is not recognized), but an environment variable NLS_LAND should not prevent scripts from executing.

The encoding setting is required because our scripts do have that encoding.

Any help on this topic would be appreciated!

user8632123

PS: I am using sqlci 20.2 on a Windows-10-machine.

Nachricht geƤndert durch user8632123

Comments
Post Details
Added on Aug 4 2020
3 comments
109 views