Skip to Main Content

Live migration between servers in a pool - shows 'failure' but works ?

User_S1173Apr 1 2019 — edited Apr 1 2019

Hi.

I have just live migrated a vm between servers in a pool.

The task showed as 'Failure' in Oracle VM manager but seems to have migrated fine.

The task output in the manager shows

---------------------------------------------------

Message:     OVMAPI_6000E Internal Error: OVMAPI_5001E Job: 1554139124051/Migrate VM: VM1 to Server: ng2-orcvms-app3/Migrate VM: VM1 to Server: ng2-orcvms-app3, failed. Job Failure Event: 1554139311295/Server Async Command Failed/OVMEVT_00C014D_001 Async command failed on server: ovs1. Object: VM1, PID: 6423, Server error: Command: ['xm', 'migrate', '--live', '0004fb0000060000f83decd004700d94', '10.168.**.***'] failed (1): stderr: Error: 'NoneType' object has no attribute 'has_key' stdout: Usage: xm migrate <Domain> <Host> Migrate a domain to another machine. Options: -h, --help Print this help. -l, --live Use live migration. -p=portnum, --port=portnum Use specified port for migration. -n=nodenum, --node=nodenum Use specified NUMA node on target. -s, --ssl Use ssl connection for migration. -c, --change_home_server Change home server for managed domains. --vmfiles="src:dst,src:dst,..." Files for use with storage migration utility , on server: ovs1, associated with object: 0004fb0000060000f83decd004700d94 [Mon Apr 01 18:21:51 BST 2019]

---------------------------------------------------

I migrated from a OVS server version 3.4.4 -> 3.4.6

(I have hashed out parts of the IP BTW)

Should I be worried ?

Thanks

Comments
Post Details
Added on Apr 1 2019
1 comment
159 views