Skip to Main Content

Java stored procedure NoClassDefFoundError

Ramesh_RFeb 5 2010 — edited Oct 15 2014
Hi All,
I have a webservice client created using Jdeveloper.
When tried to run the client in JDeveloper its running fine.
I have loaded the entire java class files into the Database.
I created a wrapper function in oracle and tried to invoke the webservice client its showing the Error
ORA- 298532: Java call terminated by uncaught java exception
I found in the user_objects and the class is available with 'VALID' status
What would be possible cause

Adding the update,
I have loaded all the required jar files also in to the database.
Actually i can able to connect to other webservices too, but not to a single webservice only...
The trace for the error is
at HTTPClient.HTTPClientSSLFactory.class$(
at HTTPClient.HTTPClientSSLFactory.<clinit>(
>> at HTTPClient.HTTPConnection.getSSL(
>> at HTTPClient.HTTPConnection.getSSLSocket(
>> at HTTPClient.HTTPConnection.doConnect(
>> at HTTPClient.HTTPConnection.sendRequest(
>> at HTTPClient.HTTPConnection.handleRequest(
>> at HTTPClient.HTTPConnection.setupRequest(
>> at HTTPClient.HTTPConnection.Post(
>> at
>> at oracle.soap.transport.http.OracleSOAPHTTPConnection.send(
>> at org.apache.soap.messaging.Message.send(


Edited by: Ramesh_R on Feb 5, 2010 9:43 AM

Edited by: Ramesh_R on Feb 5, 2010 10:48 PM
Post Details
Locked due to inactivity on Mar 5 2010
Added on Feb 5 2010