Skip to Main Content

Java APIs

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Java Applications not shown in jvisualvm

jeff_gaerFeb 11 2015 — edited Feb 11 2015

When invoking jvisualvm I do no see any running java applications under local except jvisualvm. As a simple test I created a java class that simply looped once a minute in the main method and output the loop count. I made sure that it was started using the same jdk as jvisualvm was run with. I then started jvisualvm and only saw the jvisual vm process.

jgaer@ljgaer_/data/R5.1/Test/src: which java
/usr/java/default/bin/java
jgaer@ljgaer_
/data/R5.1/Test/src: java -cp . Test2
loop
0 ....

jgaer@ljgaer_
~/jvvm: which jvisualvm
/usr/java/default/bin/jvisualvm
jgaer@ljgaer_
~/jvvm: jvisualvm --jdkhome "/usr/java/default" --userdir `pwd`


There are no exeptions to the console or in the messages.log file.

The top of the log shows

>Log Session: Wednesday, February 11, 2015 9:30:38 AM CST >System Info: Product Version = Java VisualVM Operating System = Linux version 2.6.18-274.el5 running on i386 Java; VM; Vendor = 1.7.0_67; Java HotSpot(TM) Client VM 24.65-b04; Oracle Corporation Runtime = Java(TM) SE Runtime Environment 1.7.0_67-b01 Java Home = /usr/java/jdk1.7.0_67/jre System Locale; Encoding = en_US (visualvm); UTF-8 Home Directory = /home/jgaer Current Directory = /home/jgaer/jvvm User Directory = /home/jgaer/jvvm Cache Directory = /home/jgaer/jvvm/var/cache Installation = /usr/java/default/lib/visualvm/visualvm /usr/java/default/lib/visualvm/profiler /usr/java/default/lib/visualvm/platform
Comments
Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Mar 11 2015
Added on Feb 11 2015
0 comments
970 views