Skip to Main Content

Java 1.8.0_31 for Solaris Sparc missing Firefox plugin

stevelynnFeb 27 2015 — edited Feb 27 2015

Until now I didn't realize that Oracle planned to deprecate (Oracle) Solaris in favor of Linux.

Since updates to Java 7 will be ending in April 2015, I thought it would be a good idea to migrate to Java 8.  I installed Java 1.8.0_31 on our Solaris 10 server and then tried to configure the Java plugin for Firefox.  Low and behold!  It is no longer supplied with the Java installation.  Apparently, when Oracle removed 32-bit support for java in Solaris, they removed Java Web Start (javaws.jar) and the Firefox plugin ( with it.  As I searched the web in vain for a solution, I recall that additional java functionality has been removed from the Java 8 build for Solaris as well, but I can't recall what they are right now.

Of course, Linux remains fully supported!!  Too bad we invested in an all-Oracle solution for our aging Oracle Forms applications.  I guess now we need to stay on Java 7 until we can migrate off the high performance (Oracle) Solaris dinosaur to a better supported Linux platform.  Thanks Oracle for providing no risk solutions.

I've submitted a ticket to Oracle Support regarding how to get past this issue, but I thought I'd throw it out here too:

How can I run a java app (like Oracle Forms) using Firefox on Solaris without a Java plugin?

Post Details
Added on Feb 27 2015