Skip to Main Content

install redhat-lsb-core on Oracle Linux 9

User_AZLW7Jan 16 2023

Hi,
when I tried to install redhat-lsb-core with yum the result was

[root@localhost Scaricati]# yum install redhat-lsb-core
Last metadata expiration check: 0:22:45 ago on Mon 16 Jan 2023 12:34:59 CET.
No match for argument: redhat-lsb-core
Error: Unable to find a match: redhat-lsb-core

so, I searched rpm, but on install it

root@localhost Scaricati]# rpm -i redhat-lsb-core-4.1-47.el8.x86_64.rpm
warning: redhat-lsb-core-4.1-47.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY
error: Failed dependencies:
/bin/mailx is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/bin/ar is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/bin/m4 is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/bin/patch is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/bin/strings is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/bin/strip is needed by redhat-lsb-core-4.1-47.el8.x86_64
/usr/sbin/sendmail is needed by redhat-lsb-core-4.1-47.el8.x86_64
ncurses-compat-libs(x86-64) is needed by redhat-lsb-core-4.1-47.el8.x86_64
redhat-lsb-submod-security(x86-64) = 4.1-47.el8 is needed by redhat-lsb-core-4.1-47.el8.x86_64
spax is needed by redhat-lsb-core-4.1-47.el8.x86_64

I understood that the situation is of a dog that is tring to bite his tail...
How can I add a repository for resolve automatically dependency?

Thanks a lot, M

This post has been answered by Sergio-Oracle on Jan 16 2023
Jump to Answer
Comments
Post Details
Added on Jan 16 2023
5 comments
73 views