Skip to Main Content
This is a BETA environment
This environment is only for testing and may be reset multiple times during the testing period. We will be frequently upgrading this BETA environment, so check back often for changes. Please assist us by providing feedback via the bug icon to the left of your profile avatar. For the current active community, visit https://community.oracle.com/tech/developers/.

How to configure Single Sign-on for Apex 4.0.2 websheet application?

My709939yaJul 28 2011
Hello all,

We have in our environment :
Database 11.2.0.2
Apex 4.0.2 configured with APEX Listener
SSO installed

In schema APEX_040000:
@C:\download\ssosdk902\packages\loadsdk.sql

Logged in SSO server administration console > Administer Partner Applications > Add Partner Application

I have noted the :
Site ID, Site TOKEN, Encryption Key, SSO URL (login and logout)

Went back to APEX_040000:
start custom_auth_sso_902.sql

start custom_auth_sso_902.plb

grant execute on wwv_flow_custom_auth_sso to apex_public_user;

grant execute on wwv_flow_custom_auth_sso to anonymous;

alter package wwv_flow_custom_auth_sso compile body;

create public synonym wwv_flow_custom_auth_sso for apex_040000.wwv_flow_custom_auth_sso;

grant execute on wwv_flow_custom_auth_sso to APEX_PUBLIC_USER;


Logged in APEX 4.0.2 and created a database application. I have changed the current authentication scheme for the one "Based on authentication scheme from gallery:Oracle Application Server Single Sign-On (Application Express as Partner Application)"
I have then tried creating a websheet application. Under Properties > Authentication > chose Single Sign-On. Before applying the changes, APEX had me create an ACL.

When accessing the database application, SSO works fine. With the websheet application, I get the following error:

Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.
Error ERR-7620 Could not determine workspace for application (100).
OK

I get the same message with Firefox too...

Did I miss a step ? I have tried looking for a complete Oracle documentation on how to properly implement SSO for a websheet application in APEX 4.0 but couldn't find any...

Any help would be really appreciated!

Regards,
Myriam
Comments
Post Details
Added on Jul 28 2011
0 comments
110 views