Skip to Main Content

ODP.NET

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Error while consuming ODAC21.10Xcopy_x64 (Oracle.DataAccess version - 4.122.21.1)

Vin AwNov 17 2023 — edited Nov 17 2023

Hi All,

I am upgrading to Oracle.DataAccess version - “4.122.21.1” from “4.122.1.0” and getting below error.

Also Verified -

 - Process is running in x64 Architecture.  
 - Uninstalled all old ODAC including GAC as well.  
 - Also verified registry, no reference of “4.122.1.0” Oracle.DataAccess.  
 - Verified from Process explorer, Only latest Oracle.DataAccess is getting referenced  from GAC.  
 - No reference of “4.122.1.0” Oracle.DataAccess in solution.

Error -

Could not load file or assembly 'Oracle.DataAccess, Version=4.122.1.0, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040). Stack trace: at Microsoft.Practices.EnterpriseLibrary.Data.DatabaseConfigurationView.GetDefaultMapping(String name, String dbProviderName)
at Microsoft.Practices.EnterpriseLibrary.Data.DatabaseConfigurationView.GetProviderMapping(String name, String dbProviderName)
at Microsoft.Practices.EnterpriseLibrary.Data.DatabaseCustomFactory.CreateObject(IBuilderContext context, String name, IConfigurationSource configurationSource, ConfigurationReflectionCache reflectionCache)

Please suggest the approach to fix the issue.

Thanks,

Vineet

This post has been answered by Vin Aw on Nov 20 2023
Jump to Answer
Comments
Post Details
Added on Nov 17 2023
6 comments
153 views