Skip to Main Content

Oracle Database Discussions

Error Oracle 19c: ORA-20000: Unable to set values for index ....: does not exist or insufficient pri

I am working with Oracle version 19c, when exporting a schema with the DATAPUMP tool I do not get any errors, it shows me that it is generated correctly, but when importing with the same tool (DATAPUMP) it shows me around 300 errors like the following:
ORA-20000: Unable to set values ​​for index ....: does not exist or insufficient privileges

And when comparing the schemas I see that the Primary Key indexes have not been created and the PKs are related to another index in which the PK columns match, even though they are not in the same order, for example:

The way the index should be found is as follows:

I have previously investigated the problem on the internet and it is mentioned that when applying an EXCLUDE of Statistics in the import the error is solved and indeed in the import log the error is no longer found, but there is still the problem of the movement of the indexes related to the PK, I already tried to EXCLUDE the Statistics from the export and later import the schema but the problem remains the same.

Do you know of any way to prevent this movement from being made when importing the schema or some way to disable the "intelligence" of the manager to relate the PK to an already existing index that is not appropriate?

Note: Before working with version 19c, we worked with version 12cR2 and this problem did not occur

This post has been answered by Ariagna Bandala salazar on Apr 12 2022
Jump to Answer
Post Details
Added on Apr 8 2022