Skip to Main Content

ERROR OGG-05263 No GGSCHEMA clause was specified in the GLOBALS file.

andreitc-OracleApr 18 2022 — edited Apr 18 2022

Hi,
So I have a problem with GG running on Windows 10.
I am trying to setup a replication between an SQL Server Machine (this Windows 10) and an Oracle 19c running on another Oracle Linux VM.
I followed the steps in the tutorials i found and everything worked ok, until i reached "add trandata HR.rep_tab". This throws "ERROR OGG-05263 No GGSCHEMA clause was specified in the GLOBALS file. Specify a GGSCHEMA schema name".
Now I found out here than this was already discusses: https://community.oracle.com/tech/apps-infra/discussion/4099811/golden-gate-ogg-05263-no-ggschema-clause-was-specified-in-the-globals-file
But for me this does not work... i don't really know why

So, let's take it from the beginning. I understand that this file needs to be under root container (GG installation folder). I am trying to create it from ggsci.
"GGSCI >" edit params ./GLOBALS
-> next a notepad terminal openes up saying "Cannot find ./GLOBALS file. Do you want to create it?"-> I click yes.
-> I add GGSCHEMA HR in the notepad file and ctrl+s to save it (without any extension)
If I input:
"GGSCI >" view params ./GLOBALS, it is prompted into ggsci terminal GGSCHEMA HR
However, when I try to "add trandata HR.rep_tab", it throws that error (see attached pictured)

I also tried to restart the manager, and also tried to run add trandata by logging into the sql server database (dblogin sourcedb gg)
What else can i do?
Thanks!
Capture.PNG

Comments
Post Details
Added on Apr 18 2022
3 comments
68 views