Skip to Main Content

Error acessing web service with SSL with Basic Authentication HTTP

719469Sep 2 2009 — edited Sep 9 2009
I have deployed a web service to a WebLogic server 10.1.3 and created a mediator endpoint to it which I also deployed.

With Enterprise Manager, first applied wss_http_token_service_policy policy to this endpoint, and tried to access it with a web service proxy created with JDeveloper with success.

Second, changed the policy to wss_http_token_over_ssl_service_policy to the same endpoint, changed the protocol and port in the wsdl file, rebuild and executed again, but now with error.

The error is:

Exception in thread "main" SecurityTokenUnavailable : The expected security token is not found in the WS-Security security header.
at $Proxy28.execute(Unknown Source)
at xxx.Execute_ptClient.main(
Process exited with exit code 1.

I inserted the correct http authentication credentials in the proxy, and it correctly access the web service when SSL is not used.

Can't figure out what is wrong. I got the same error when accessing this web service through the test page inside Enterprise Manager.

Any help?

Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked due to inactivity on Oct 7 2009
Added on Sep 2 2009
1 comment