Skip to Main Content

E1Page: Two identical users, one can see E1Page while other cannot

NimishPrabhuAug 26 2016


We have a situation where we have created and published 2 E1pages (Say, Page1 and Page2).

We have two users and one role created to test these pages.



Both users are created using standard process, i.e. create user in P0092, assign mentioned role in P95921 and create P98OWSEC record.

There are no other changes made for these users. Role INDSTMGR has been given necessary UDO view and action securities.

Now, for user NIMTEST, we are able to see both E1Pages while for user STMGR we are unable to see anything in that context frame (Frame is empty, not even JDE 9.2 screen is display).

But while logging in, if we specify the role "INDSTMGR" instead of "*ALL", E1Pages are displayed properly. (Note: NIMTEST, which is exactly similar to STMGR, can see E1Pages with *ALL)

When user STMGR, logs in with *ALL role, we can see following error message in the e1root logs:

25 Aug 2016 18:49:59,415[SEVERE][JAS]WOUtilityManagerThreads() had caught an exception for U-DO Cat (E1PAGE) : org.w3c.dom.DOMException: NOT_FOUND_ERR: An attempt is made to reference a node in a context where it does not exist.

We tried taking Call object kernel logs and application level activity logs but there are no error messages in the same. We also tried to delete and recreate the user, but still the issue persists.

Application release: 9.2


Any advice on what might be causing the issue and how to resolve it, is highly appreciated.

Post Details
Added on Aug 26 2016