Skip to Main Content

Enterprise Manager

Creating Physical Standby Hits Error at Step 3

4196196Feb 26 2020 — edited Mar 9 2020

Trying to create a physical standby using OEM 13.3 hits a brick wall at step 3. The step where you select the standby host and standby OH.

Basically, OEM will not display ANY compatible OH on any other host apart from the OH on the primary host. The standby host has a compatible OS and compatible OH. Both the standby host and the standby OH are visible via OEM.

Here's my setup:

Primary / standby host: orasvr01 / orasvr03

Primary / standby host OS: OL 7.7 / OL 7.7

Primary / standby DB version: 18.3 / 18.3

In a previous configuration a few years ago, using OEM 12.5 and DB version 12.1, I had the same issue but managed to fix it. When it's fixed and working correctly, you see the screen shot "OEM 12c Screen Shot.png" when you click the magnifying glass to select the standby host and OH. Unfortunately I can't remember what I did to get around this. Clicking the magnifying glass in OEM 13.3 shows me the screen shot "OEM 13c screen shot.png". Notice how it doesn't even display the OS or OS version. Seems suspicious, like there's a bug stopping the discovery from working correctly.

Here's what I've tried:

- deployed the database plug-in to the agent;

- decommissioned the agent, uninstalled, re-installed & re-discovered all relevant targets;

- followed MOS Doc ID 1988557.1 (which is riddled with errors/typos and still doesn't fix it);

- tried it with 12.2 OH with same result;

Any suggestions, workaround or fixes would be so gratefully received.

Many thanks in advance.

Comments
Post Details
Added on Feb 26 2020
9 comments
554 views