Skip to Main Content

Oracle Database Free

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Cannot install oracle database free 23c on OracleLinux 9.3 for many reasons

Paolo BergomiFeb 13 2024 — edited Feb 13 2024

Hi,

I have a weird situation

here some package details of my environment

“Hardware” : Virtual Box 7.0 Version 7.0.12 r159484 (Qt5.15.2)

OS:

Kernel 5.15.0-202.135.2.el9uek.x86_64

Red Hat Enterprise Linux release 9.3 (Plow)

It seems perfecly working.

But…

Following the official tutorial for the DB installation, i start with the “preinstall” that will create oracle user, filled the etc/sysctl.conf file and other stuff:

first thing . i have done this, preventively

dnf clean all

dnf update -y

dnf makeache

After that, i try to install the package but before, i downloead it locally

I used this reference guide

Oracle Database Free Installation Guide, 23c for Linux x86-64

isee there there is also a reference to Developer Day - Hands-on Database Application Development (oracle.com)

Perhaps, i have to follow that path? i am not sure, so i tried with the other way, starting with teh preinstallation

once i downloaded this file into my machine i run

oracle-database-preinstall-23c-1.0-0.5.el8.x86_64.rpm

but i got this error:

[root@MyRouter ~]# dnf localinstall -y oracle-database-preinstall-23c-1.0-0.5.el8.x86_64.rpm
Last metadata expiration check: 1:03:05 ago on Tue 13 Feb 2024 15:26:59.
Error:
Problem: conflicting requests

  • nothing provides compat-openssl10 needed by oracle-database-preinstall-23c-1.0-0.5.el8.x86_64 from @commandline
    (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

SO i am not sure what to do,

i tried install to do

dnf search oracle-database-preinstall*

but with my surprise it finds only this version

[root@MyRouter ~]# dnf search oracle-database-preinstall
Last metadata expiration check: 1:04:57 ago on Tue 13 Feb 2024 15:26:59.
========================================================= Name Matched: oracle-database-preinstall ==========================================================
oracle-database-preinstall-19c.x86_64 : Oracle Database Preinstallation RPM
oracle-database-preinstall-19c.src : Oracle Database Preinstallation RPM
[root@MyRouter ~]#

no tracks of the 23c

Is there anyone who knows how to do the preinstallation of the 23c in my machine? Or has a clue about what happens?

Thanks in advance.

Paolo

Comments
Post Details
Added on Feb 13 2024
7 comments
681 views