Skip to Main Content

Enterprise Manager

Announcement

For appeals, questions and feedback, please email oracle-forums_moderators_us@oracle.com

Can't start Oracle Enterprise Manager Webtier after enabling SSL with error "Cannot open wallet.."

User_UK44EJun 28 2019 — edited May 1 2020

Hi Gurus,

I inherited a Oracle Enterprise Manager 13c R2  and am trying to enable SSL for several major ports so we can access OEM console via

https.

I was following "EM13c, 12: How to configure the Oracle Enterprise Manager Management Service (OMS) with SSL Certificates (doc ID

2202569.1)" to use orapki to

1) create a wallet (with auto_login option),

2) generate a certificate request, sent to CA, get certificate (user, intermediate, and root) back.

3) Imported all the certificates successfully, and

4) configured  httpd_em.conf, ssl.conf, and ssl_bip.conf (for all configuration at both server and instance level)

First I was able to start OMS with all components, however after I applied the latest patches (DB, WebLogic and OMS), i could not start Webtier up with "WebTier Could Not Be Started" message.

Looking through the $EM_BASE/em/gc_inst/user_projects/domains/GCDomain/servers/ohs1/logs/ohs1.log file I can see error message as following:

Server doc.gss.dte.cert.org:9851: Cannot open wallet file:/oracle/software/em/gc_inst/user_projects/domains/GCDomain/config/fmwconfig/components/OHS/instances/ohs1/keystores/console, unable to prompt for password. Enable it as an Auto Login or clear wallet or configure SSLPassPhraseDialog

However  I know my oracle wallet was created a auto_login with both cwallet.sso and ewallet.p12 created in the wallet, and it worked for couple days.

I wonder why all the suddent it stopped working, did I miss anything here?

Thanks,

Alan Wan

Comments
Post Details
Added on Jun 28 2019
2 comments
318 views