Skip to Main Content

DevOps, CI/CD and Automation

Can't run my Web Site app that used to work in .Net 4.0

user10703969Oct 21 2015 — edited Oct 22 2015

I had a web site that worked.  It used .Net 2.x.  Lately I had to look at that code again.  I migrated it to 4.0.  I used ODAC 12 Oracle.DataAccess.dll.  I'm having various problems and my actual server is only 11g.  The customer I was trying to help found that by installing some version 11 ODAC files, it worked for her.

So I went to the Oracle ODAC download site.  I downloaded this:

 Download the Oracle Universal Installer version           [Released December 28, 2010] 227 MB (238,256,403 bytes)
Installation Instructions

Download Includes

 Oracle Data Provider for .NET 4
 Oracle Data Provider for .NET 2.0
 Oracle Providers for ASP.NET 4
 Oracle Providers for ASP.NET 2.0
 Oracle Database Extensions for .NET 4 -- for upgrade only
 Oracle Database Extensions for .NET 2.0 -- for upgrade only
 Oracle Provider for OLE DB
 Oracle Objects for OLE
 Oracle Services for Microsoft Transaction Server
 Oracle ODBC Driver
 Oracle SQL*Plus
 Oracle Instant Client

   Ah, there is the .Net 4 stuff, I thought.  So I transferred the downloaded file to my Win7 development box.  Ran the setup and install.  Guess what?  It only shows options for installing .Net 2.0 stuff.

What is going on?  Where should I get some 11 g drivers that work with .Net 4?

Locked Post
New comments cannot be posted to this locked post.
Post Details
Locked on Nov 19 2015
Added on Oct 21 2015